CVE-2026-72767 n8n before 1.123.67 Remote Code Execution via Git node

High 8.7 Published Updated

Authenticated users can execute arbitrary commands via crafted Git repositories in n8n, leading to remote code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-72767?

CVE-2026-72767 is a high-severity command injection vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n before 1.123.67, 2.x before 2.31.5, and 2.32.x before 2.32.1 contain a remote code execution vulnerability in the Git node. Authenticated users with rights to create and execute workflows can stage a crafted local repository that causes git to run hooks under default git security settings, executing arbitrary commands as the n8n process user. Both self-hosted and cloud instances are affected.

Weakness: CWE-78

Which versions are affected by CVE-2026-72767?

6 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions1.123.67
n8n npmAll versions1.123.67
n8n npmFrom 2.0.0-rc.02.31.5
n8n npmFrom 2.0.0-rc.02.31.5
n8n npmFrom 2.32.02.32.1
n8n npmFrom 2.32.02.32.1

Products include N8n N8n.

How do I fix CVE-2026-72767?

Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-72767 being exploited?

There is no known exploitation of CVE-2026-72767 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-rcv6-pvrj-4xcg, GHSA-rvvp-8h68-7hqm, MINI-g7h8-4rmq-h445, MINI-jrp6-r4f5-prqc, ROOT-APP-NPM-GHSA-rcv6-pvrj-4xcg.

Is CVE-2026-72767 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free