CVE-2026-72769 n8n before 1.123.67 Prototype Pollution via VM Expression Engine
Authenticated users can cause denial of service in n8n by polluting prototypes via the VM expression engine sandbox escape.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72769?
CVE-2026-72769 is a medium-severity code injection vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 1.123.67, 2.31.5, and 2.32.1 contains a prototype pollution vulnerability in the VM expression engine. An authenticated user able to create or edit a workflow expression can abuse the engine's array-element access to obtain a reference to a host built-in and pollute its prototype in the main n8n process (a sandbox escape), leading to a denial of service. Both self-hosted and cloud instances running the VM expression engine are affected.
Weakness: CWE-1321
Which versions are affected by CVE-2026-72769?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.67 |
n8n npm | All versions | 1.123.67 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.32.0 | 2.32.1 |
n8n npm | From 2.32.0 | 2.32.1 |
Products include N8n N8n.
How do I fix CVE-2026-72769?
Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-72769 being exploited?
There is no known exploitation of CVE-2026-72769 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-83p6-2p5w-42rc, GHSA-hx4h-vr3m-45vh, MINI-8272-2797-87wj, MINI-qf38-rf49-r7mg.