# CVE-2026-72769: n8n before 1.123.67 Prototype Pollution via VM Expression Engine

> Authenticated users can cause denial of service in n8n by polluting prototypes via the VM expression engine sandbox escape.

- **Severity:** Medium 6.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-83p6-2p5w-42rc, GHSA-hx4h-vr3m-45vh, MINI-8272-2797-87wj, MINI-qf38-rf49-r7mg

## What is CVE-2026-72769?

CVE-2026-72769 is a medium-severity code injection vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n before 1.123.67, 2.31.5, and 2.32.1 contains a prototype pollution vulnerability in the VM expression engine. An authenticated user able to create or edit a workflow expression can abuse the engine's array-element access to obtain a reference to a host built-in and pollute its prototype in the main n8n process (a sandbox escape), leading to a denial of service. Both self-hosted and cloud instances running the VM expression engine are affected.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-72769?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.67 |
| `n8n` | npm | All versions | 1.123.67 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.31.5 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.31.5 |
| `n8n` | npm | From 2.32.0 | 2.32.1 |
| `n8n` | npm | From 2.32.0 | 2.32.1 |

Products: N8n N8n.

## How do I fix CVE-2026-72769?

Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.

## Is CVE-2026-72769 being exploited?

There is no known exploitation of CVE-2026-72769 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72769 and fix it if it is affected.

What it is: CVE-2026-72769 is a medium-severity code injection vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72769 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.67
- n8n (npm): affected all versions; fixed in 1.123.67
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.31.5
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.31.5
- n8n (npm): affected from 2.32.0; fixed in 2.32.1
- n8n (npm): affected from 2.32.0; fixed in 2.32.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72769/ (Markdown: https://insights.sbomify.com/CVE-2026-72769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72769
- OSV: https://osv.dev/vulnerability/CVE-2026-72769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72769/
Summaries are generated and may contain mistakes; the official description above is the record.
