CVE-2026-72771 n8n before 2.32.1 Credential Restriction Bypass via AI/LLM Nodes

High 7.1 Published Updated

Low-privileged users can bypass domain restrictions in AI nodes to exfiltrate credential secrets from shared workflows.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-72771?

CVE-2026-72771 is a high-severity vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n versions before 2.32.1 fail to enforce the Allowed HTTP Request Domains allowlist in multiple AI and LLM nodes when user-supplied base or endpoint URLs are configured. Low-privileged workflow editors with use-only access to shared credentials can redirect requests to attacker-controlled hosts and exfiltrate credential secrets for reuse against underlying services.

Weakness: CWE-863

Which versions are affected by CVE-2026-72771?

4 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions2.31.5
n8n npmAll versions2.31.5
n8n npmFrom 2.32.02.32.1
n8n npmFrom 2.32.02.32.1

Products include N8n N8n.

How do I fix CVE-2026-72771?

Upgrade n8n to a fixed version for your release line: 2.31.5 or 2.32.1.

Is CVE-2026-72771 being exploited?

There is no known exploitation of CVE-2026-72771 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-64xh-79j6-r5v8, GHSA-h7wc-28g5-h4g8, MINI-7fgj-vv5g-wx84, MINI-pr9v-qcvw-44wh, ROOT-APP-NPM-GHSA-64xh-79j6-r5v8.

Is CVE-2026-72771 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free