CVE-2026-72774 n8n before 1.123.67 Authentication Bypass via HTTP Request Node
Authenticated users with edit access can bypass credential ownership checks in the HTTP Request node to use or exfiltrate other users' credentials.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72774?
CVE-2026-72774 is a high-severity authentication bypass vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 1.123.67, 2.31.5, and 2.32.1 contains a credential authorization bypass in the HTTP Request node. An authenticated member with edit access to a shared workflow can reference another user's credential while specifying the credential type via an expression. Because the pre-execution permission check compares the unresolved expression instead of the resolved credential type, the ownership check is skipped and the credential is loaded at execution time, allowing the member to use or exfiltrate a credential they were not granted. Exploitation requires knowing the target credential's identifier.
Weakness: CWE-639
Which versions are affected by CVE-2026-72774?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.67 |
n8n npm | All versions | 1.123.67 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.32.0 | 2.32.1 |
n8n npm | From 2.32.0 | 2.32.1 |
Products include N8n N8n.
How do I fix CVE-2026-72774?
Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-72774 being exploited?
There is no known exploitation of CVE-2026-72774 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-6qc9-mqvw-jg7x, GHSA-r3ww-gmwx-48xw, MINI-997q-p844-wqvc, MINI-cc7v-pgjj-mv4c, ROOT-APP-NPM-GHSA-6qc9-mqvw-jg7x.