# CVE-2026-72774: n8n before 1.123.67 Authentication Bypass via HTTP Request Node

> Authenticated users with edit access can bypass credential ownership checks in the HTTP Request node to use or exfiltrate other users' credentials.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-6qc9-mqvw-jg7x, GHSA-r3ww-gmwx-48xw, MINI-997q-p844-wqvc, MINI-cc7v-pgjj-mv4c, ROOT-APP-NPM-GHSA-6qc9-mqvw-jg7x

## What is CVE-2026-72774?

CVE-2026-72774 is a high-severity authentication bypass vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n before 1.123.67, 2.31.5, and 2.32.1 contains a credential authorization bypass in the HTTP Request node. An authenticated member with edit access to a shared workflow can reference another user's credential while specifying the credential type via an expression. Because the pre-execution permission check compares the unresolved expression instead of the resolved credential type, the ownership check is skipped and the credential is loaded at execution time, allowing the member to use or exfiltrate a credential they were not granted. Exploitation requires knowing the target credential's identifier.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-72774?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.67 |
| `n8n` | npm | All versions | 1.123.67 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.31.5 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.31.5 |
| `n8n` | npm | From 2.32.0 | 2.32.1 |
| `n8n` | npm | From 2.32.0 | 2.32.1 |

Products: N8n N8n.

## How do I fix CVE-2026-72774?

Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.

## Is CVE-2026-72774 being exploited?

There is no known exploitation of CVE-2026-72774 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72774 and fix it if it is affected.

What it is: CVE-2026-72774 is a high-severity authentication bypass vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72774 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.67
- n8n (npm): affected all versions; fixed in 1.123.67
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.31.5
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.31.5
- n8n (npm): affected from 2.32.0; fixed in 2.32.1
- n8n (npm): affected from 2.32.0; fixed in 2.32.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72774/ (Markdown: https://insights.sbomify.com/CVE-2026-72774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72774
- OSV: https://osv.dev/vulnerability/CVE-2026-72774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72774/
Summaries are generated and may contain mistakes; the official description above is the record.
