CVE-2026-72775 n8n before 1.123.67 SQL Injection via PostgresTrigger Node
An authenticated user can inject arbitrary SQL into the PostgresTrigger node, allowing full read and write access to the connected database.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72775?
CVE-2026-72775 is a medium-severity SQL injection vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 1.123.67, 2.31.5, and 2.32.1 contains a SQL injection vulnerability in the PostgresTrigger node, which interpolates user-supplied identifier parameters (channel, function, and trigger names) into SQL statements without proper escaping. An authenticated user can inject arbitrary SQL executed against the connected PostgreSQL database with the configured credential's privileges, allowing full read and write access.
Weakness: CWE-89
Which versions are affected by CVE-2026-72775?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.67 |
n8n npm | All versions | 1.123.67 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.32.0 | 2.32.1 |
n8n npm | From 2.32.0 | 2.32.1 |
Products include N8n N8n.
How do I fix CVE-2026-72775?
Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-72775 being exploited?
There is no known exploitation of CVE-2026-72775 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-jqwr-vx3p-r266, GHSA-m6wx-qjxf-vr9v, MINI-8cg2-58rq-rr28, MINI-c4w3-95p6-mqvv.