CVE-2026-72778 Craft CMS 5.0.0-RC1 before 5.10.6 Authenticated RCE via condition.config
Authenticated attackers can execute arbitrary code via unsafe JSON decoding in Craft CMS control panel condition handling.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72778?
CVE-2026-72778 is a high-severity code injection vulnerability in craftcms cms, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Craft CMS versions from 4.0.0-RC1 before 4.18.2 and from 5.0.0-RC1 before 5.10.6 contain an authenticated remote code execution vulnerability in the control panel element-search condition handling. Craft cleanses the outer request-controlled condition array via Component::cleanseConfig(), but Conditions::createCondition() later decodes and merges the JSON string in condition.config without re-running cleanseConfig() on the decoded configuration. Because condition.config is a JSON string during the first cleanse, Yii special config keys such as 'as ...' and 'on ...' can be hidden inside it and, after JSON decoding, are interpreted by Yii as behavior/event configuration during FieldLayout object creation. An attacker with an authenticated control panel session (and a valid CSRF token) can exploit this to execute operating system commands as the PHP/web user.
Weakness: CWE-915
Which versions are affected by CVE-2026-72778?
4 open source packages ship an affected version, including craftcms/cms.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.18.2 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.18.2 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.10.6 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.10.6 |
How do I fix CVE-2026-72778?
Upgrade craftcms/cms to a fixed version for your release line: 4.18.2 or 5.10.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-72778 being exploited?
There is no known exploitation of CVE-2026-72778 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-265m-7826-wjqm.