# CVE-2026-72780: Craft CMS before 5.10.5 WebAuthn Assertion Replay via login-with-passkey

> Attackers can replay WebAuthn assertions to hijack user accounts in Craft CMS due to missing counter updates.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-jh4m-63fq-p9h9, GHSA-wg23-69c2-gjc8

## What is CVE-2026-72780?

CVE-2026-72780 is a high-severity authentication bypass vulnerability in craftcms cms, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft CMS before 5.10.5 fails to persist updated credential counters after WebAuthn assertion validation in the passkey login endpoint. Attackers can replay captured login request bodies containing requestOptions and response to create additional authenticated sessions for victim accounts.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2026-72780?

2 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.5 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.5 |

## How do I fix CVE-2026-72780?

Upgrade craftcms/cms to 5.10.5 or later.

## Is CVE-2026-72780 being exploited?

There is no known exploitation of CVE-2026-72780 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72780 and fix it if it is affected.

What it is: CVE-2026-72780 is a high-severity authentication bypass vulnerability in craftcms cms, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72780 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.5
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72780/ (Markdown: https://insights.sbomify.com/CVE-2026-72780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72780
- OSV: https://osv.dev/vulnerability/CVE-2026-72780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72780/
Summaries are generated and may contain mistakes; the official description above is the record.
