{"answers":{"affected":"4 open source packages ship an affected version, including craftcms/cms.","exploited":"There is no known exploitation of CVE-2026-72781 in the wild and no public exploit code.","fix":"Upgrade craftcms/cms to a fixed version for your release line: 4.18.3 or 5.10.7.","what":"CVE-2026-72781 is a high-severity code injection vulnerability in craftcms cms, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-72781 and fix it if it is affected.\n\nWhat it is: CVE-2026-72781 is a high-severity code injection vulnerability in craftcms cms, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-72781 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.3\n- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.3\n- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.7\n- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72781/ (Markdown: https://insights.sbomify.com/CVE-2026-72781/index.md)","id":"CVE-2026-72781","markdown":"https://insights.sbomify.com/CVE-2026-72781/index.md","name":"CVE-2026-72781","record":{"aliases":["GHSA-f5wm-88jv-g5hx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Craft CMS","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary code via Twig sandbox escape in Craft CMS, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"Craft CMS versions \u003e= 5.0.0-RC1 before 5.10.7 and \u003e= 4.0.0-RC1 before 4.18.3 contain a remote code execution vulnerability in the Twig sandbox mechanism. Because Craft marks the ElementInterface as safe (via the AllowedInSandbox attribute) and the sandbox allowlisting extends to the entire class hierarchy (craft\\base\\Component up to yii\\base\\Component), an authenticated attacker with permission to access the control panel can render a malicious Twig template that abuses the yii\\base\\Component arbitrary function-call gadget to execute arbitrary code, even when the Twig sandbox is enabled via enableTwigSandbox().","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-09-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-21T19:20:18Z","kind":"github_poc","ref":"https://github.com/TRX-0/CVE-2026-72781-craftcms-sandbox-rce","stars":0,"title":"Craft CMS CVE-2026-72781 Twig sandbox escape RCE PoC"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Craft CMS 5.0.0-RC1 before 5.10.7 Remote Code Execution via Twig Sandbox Escape","id":"CVE-2026-72781","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Craft CMS 5.0.0-RC1 before 5.10.6 Environment Variable Leak","id":"CVE-2026-72782"},"packages":[{"ecosystem":"Packagist","fixed":["4.18.3"],"introduced":["4.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-f5wm-88jv-g5hx"},{"ecosystem":"Packagist","fixed":["4.18.3"],"introduced":["4.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-f5wm-88jv-g5hx"},{"ecosystem":"Packagist","fixed":["5.10.7"],"introduced":["5.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-f5wm-88jv-g5hx"},{"ecosystem":"Packagist","fixed":["5.10.7"],"introduced":["5.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-f5wm-88jv-g5hx"}],"prev":{"headline":"Craft CMS before 5.10.5 WebAuthn Assertion Replay via login-with-passkey","id":"CVE-2026-72780"},"products":["cms"],"published":"2026-08-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["craftcms"]},"summary":"Authenticated attackers can execute arbitrary code via Twig sandbox escape in Craft CMS, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-72781/"}