# CVE-2026-72781: Craft CMS 5.0.0-RC1 before 5.10.7 Remote Code Execution via Twig Sandbox Escape

> Authenticated attackers can execute arbitrary code via Twig sandbox escape in Craft CMS, requiring an upgrade to patched versions.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-f5wm-88jv-g5hx

## What is CVE-2026-72781?

CVE-2026-72781 is a high-severity code injection vulnerability in craftcms cms, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft CMS versions >= 5.0.0-RC1 before 5.10.7 and >= 4.0.0-RC1 before 4.18.3 contain a remote code execution vulnerability in the Twig sandbox mechanism. Because Craft marks the ElementInterface as safe (via the AllowedInSandbox attribute) and the sandbox allowlisting extends to the entire class hierarchy (craft\base\Component up to yii\base\Component), an authenticated attacker with permission to access the control panel can render a malicious Twig template that abuses the yii\base\Component arbitrary function-call gadget to execute arbitrary code, even when the Twig sandbox is enabled via enableTwigSandbox().

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-72781?

4 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.18.3 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.18.3 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.7 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.7 |

## How do I fix CVE-2026-72781?

Upgrade craftcms/cms to a fixed version for your release line: 4.18.3 or 5.10.7.

## Is CVE-2026-72781 being exploited?

There is no known exploitation of CVE-2026-72781 in the wild and no public exploit code.

Public exploit code:

- Craft CMS CVE-2026-72781 Twig sandbox escape RCE PoC (github_poc): https://github.com/TRX-0/CVE-2026-72781-craftcms-sandbox-rce

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72781 and fix it if it is affected.

What it is: CVE-2026-72781 is a high-severity code injection vulnerability in craftcms cms, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72781 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.3
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.3
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.7
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72781/ (Markdown: https://insights.sbomify.com/CVE-2026-72781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72781
- OSV: https://osv.dev/vulnerability/CVE-2026-72781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72781/
Summaries are generated and may contain mistakes; the official description above is the record.
