{"answers":{"affected":"2 open source packages ship an affected version, including craftcms/cms.","exploited":"There is no known exploitation of CVE-2026-72787 in the wild and no public exploit code.","fix":"Upgrade craftcms/cms to 5.10.8 or later.","what":"CVE-2026-72787 is a medium-severity cross-site scripting vulnerability in craftcms cms, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-72787 and fix it if it is affected.\n\nWhat it is: CVE-2026-72787 is a medium-severity cross-site scripting vulnerability in craftcms cms, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-72787 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.8\n- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72787/ (Markdown: https://insights.sbomify.com/CVE-2026-72787/index.md)","id":"CVE-2026-72787","markdown":"https://insights.sbomify.com/CVE-2026-72787/index.md","name":"CVE-2026-72787","record":{"aliases":["GHSA-2rp4-x2j7-qmcc","GHSA-xh8r-pv2v-rc22"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Craft CMS","requires_auth":"low_privilege","summary":"Low-privilege users can inject JavaScript via draft names, leading to account takeover of higher-privileged users in Craft CMS.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Craft CMS versions before 5.10.8 contain a stored cross-site scripting vulnerability in the control panel where draft names are rendered without HTML encoding in element chips and cards. A low-privilege user who can create element drafts can inject malicious JavaScript that executes in the browser of any higher-privileged user viewing the affected element, allowing account creation and other authenticated actions.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Craft CMS 5.0.0-RC1 before 5.10.8 Stored XSS via Draft Name","id":"CVE-2026-72787","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"SiYuan before v3.7.4 Information Disclosure via UILayout Filter","id":"CVE-2026-72788"},"packages":[{"ecosystem":"Packagist","fixed":["5.10.8"],"introduced":["5.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-2rp4-x2j7-qmcc"},{"ecosystem":"Packagist","fixed":["5.10.8"],"introduced":["5.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-2rp4-x2j7-qmcc"}],"prev":{"headline":"Craft CMS 5.0.0-RC1 before 5.10.8 Authentication Bypass via Password Reset","id":"CVE-2026-72786"},"products":["cms"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["craftcms"]},"summary":"Low-privilege users can inject JavaScript via draft names, leading to account takeover of higher-privileged users in Craft CMS.","url":"https://insights.sbomify.com/CVE-2026-72787/"}