# CVE-2026-72804: SiYuan before v3.7.4 Authentication Bypass via Graph Endpoints

> Attackers can bypass authentication on graph endpoints to read password-protected document content and reference topology in SiYuan.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-vpjw-wf5h-cgpq, GO-2026-6407

## What is CVE-2026-72804?

CVE-2026-72804 is a critical authentication bypass vulnerability in siyuan-note siyuan, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SiYuan versions before v3.7.4 fail to validate publish-password tier in getGraph and getLocalGraph endpoints, allowing anonymous readers to retrieve block-level content of password-protected documents. Attackers can call these endpoints without supplying a password to read protected document content and the complete reference topology.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-72804?

3 open source packages ship an affected version, including github.com/siyuan-note/siyuan/kernel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260724091654-82e9ded423e4 |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260724091654-82e9ded423e4 |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260724091654-82e9ded423e4 |

## How do I fix CVE-2026-72804?

Upgrade github.com/siyuan-note/siyuan/kernel to 0.0.0-20260724091654-82e9ded423e4 or later.

## Is CVE-2026-72804 being exploited?

There is no known exploitation of CVE-2026-72804 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72804 and fix it if it is affected.

What it is: CVE-2026-72804 is a critical authentication bypass vulnerability in siyuan-note siyuan, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72804 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260724091654-82e9ded423e4
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260724091654-82e9ded423e4
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260724091654-82e9ded423e4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72804/ (Markdown: https://insights.sbomify.com/CVE-2026-72804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72804
- OSV: https://osv.dev/vulnerability/CVE-2026-72804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72804/
Summaries are generated and may contain mistakes; the official description above is the record.
