# CVE-2026-72810: SiYuan before v3.7.4 Publish-Boundary Bypass via WebSocket

> Attackers can bypass publish boundaries via WebSocket to read password-protected and forbidden documents without authentication.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-mw8r-mw84-88v2, GO-2026-6400

## What is CVE-2026-72810?

CVE-2026-72810 is a critical missing authorization vulnerability in siyuan-note siyuan, published on 14 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SiYuan versions before v3.7.4 contain a publish-boundary bypass vulnerability in WebSocket broadcast sessions that allows anonymous readers to receive unfiltered edits. Attackers can establish a WebSocket connection to the publish surface and passively receive real-time content events including password-protected and forbidden documents without authentication.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-72810?

3 open source packages ship an affected version, including github.com/siyuan-note/siyuan/kernel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260723013612-ba948639d7f6 |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260723013612-ba948639d7f6 |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260723013612-ba948639d7f6 |

## How do I fix CVE-2026-72810?

Upgrade github.com/siyuan-note/siyuan/kernel to 0.0.0-20260723013612-ba948639d7f6 or later.

## Is CVE-2026-72810 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72810 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72810 and fix it if it is affected.

What it is: CVE-2026-72810 is a critical missing authorization vulnerability in siyuan-note siyuan, published on 14 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72810 exists.

Affected packages and fixed versions:
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260723013612-ba948639d7f6
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260723013612-ba948639d7f6
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260723013612-ba948639d7f6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72810/ (Markdown: https://insights.sbomify.com/CVE-2026-72810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72810
- OSV: https://osv.dev/vulnerability/CVE-2026-72810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72810/
Summaries are generated and may contain mistakes; the official description above is the record.
