# CVE-2026-72814: actix-files before 0.6.10 Information Disclosure via Files

> Attackers can access unintended files by exploiting path resolution flaws when serving from non-existent folders in actix-files.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Aug 2026
- **Updated:** 29 Oct 2026
- **Also known as:** CLEANSTART-2026-QW59159, GHSA-8v2v-wjwg-vx6r, GHSA-f87p-3w4v-5q9x, UBUNTU-CVE-2026-72814

## What is CVE-2026-72814?

CVE-2026-72814 is a medium-severity path traversal vulnerability in actix-files, published on 14 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The actix-files crate (actix_files) before version 0.6.10 contains an information exposure vulnerability. When a non-existing folder is passed as the serve_from argument to Files::new(), the mount path defaults to an empty path; the service then joins the request path with this empty path and canonicalizes it, causing Rust to resolve it as a relative path. As a result, an attacker can request paths that resolve relative to the application's working directory and access unintended files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-72814?

2 open source packages ship an affected version, including actix-files.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actix-files` | crates.io | All versions | 0.6.10 |
| `actix-files` | crates.io | All versions | 0.6.10 |

## How do I fix CVE-2026-72814?

Upgrade actix-files to 0.6.10 or later.

## Is CVE-2026-72814 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72814 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72814 and fix it if it is affected.

What it is: CVE-2026-72814 is a medium-severity path traversal vulnerability in actix-files, published on 14 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72814 exists.

Affected packages and fixed versions:
- actix-files (crates.io): affected all versions; fixed in 0.6.10
- actix-files (crates.io): affected all versions; fixed in 0.6.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72814/ (Markdown: https://insights.sbomify.com/CVE-2026-72814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72814
- OSV: https://osv.dev/vulnerability/CVE-2026-72814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72814/
Summaries are generated and may contain mistakes; the official description above is the record.
