{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72819 exists.","fix":"Upgrade getgrav/grav to 2.0.13 or later.","what":"CVE-2026-72819 is a high-severity vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-72819 and fix it if it is affected.\n\nWhat it is: CVE-2026-72819 is a high-severity vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72819 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.13\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72819/ (Markdown: https://insights.sbomify.com/CVE-2026-72819/index.md)","id":"CVE-2026-72819","markdown":"https://insights.sbomify.com/CVE-2026-72819/index.md","name":"CVE-2026-72819","record":{"aliases":["GHSA-r94f-hx44-8jqf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS plugin","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary code by uploading a malicious ZIP file to bypass validation in the Flex Objects plugin.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Grav CMS before 2.0.13 contains a remote code execution vulnerability in the Flex Objects plugin settings validation that allows authenticated users to execute arbitrary code by uploading a ZIP file containing PHP code. Attackers can bypass routine name validation by using array notation instead of string notation, call the unZip routine with a malicious archive, and write PHP files to the web root for execution.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav CMS before 2.0.13 Remote Code Execution via ZIP Upload","id":"CVE-2026-72819","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Grav 2.0.11 Path Traversal via Backup Profile Configuration","id":"CVE-2026-72820"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.13"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-r94f-hx44-8jqf"},{"ecosystem":"Packagist","fixed":["2.0.13"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-r94f-hx44-8jqf"}],"prev":{"headline":"NLTK TweetTokenizer URL Pattern Backtracks Catastrophically on Naked-Domain-Like Input","id":"CVE-2026-72818"},"products":["grav"],"published":"2026-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["getgrav"]},"summary":"Authenticated attackers can execute arbitrary code by uploading a malicious ZIP file to bypass validation in the Flex Objects plugin.","url":"https://insights.sbomify.com/CVE-2026-72819/"}