CVE-2026-72831 Grav through 2.0.11 Authentication Bypass via Flex Objects
Authenticated users with limited permissions can bypass authorization checks in the Flex Objects plugin to escalate privileges and take over the site.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-72831?
CVE-2026-72831 is a high-severity missing authorization vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect authorization vulnerability in its Flex Objects API. FlexApiController::update() checks only the general Flex directory permission and does not apply the additional target/field/super-admin checks enforced by the dedicated Users and Groups API controllers. An authenticated account with api.access, admin.login, and users.update permissions (but without api.users.write or admin.super) can use the generic /api/v1/flex-objects/user-accounts endpoint to change a super administrator's password, or the /api/v1/flex-objects/user-groups endpoint to grant its group admin.super, resulting in full site takeover. Fixed in Flex Objects 1.4.7.
Weakness: CWE-863
Which versions are affected by CVE-2026-72831?
How do I fix CVE-2026-72831?
No fix has been published for CVE-2026-72831 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-72831 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72831 exists.
Sources
Also known as GHSA-7cc5-h479-2c5p, GHSA-pc8m-jxvh-vmrc.