{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72831 exists.","fix":"No fix has been published for CVE-2026-72831 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-72831 is a high-severity missing authorization vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-72831 and fix it if it is affected.\n\nWhat it is: CVE-2026-72831 is a high-severity missing authorization vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72831 exists.\n\nAffected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72831/ (Markdown: https://insights.sbomify.com/CVE-2026-72831/index.md)","id":"CVE-2026-72831","markdown":"https://insights.sbomify.com/CVE-2026-72831/index.md","name":"CVE-2026-72831","record":{"aliases":["GHSA-7cc5-h479-2c5p","GHSA-pc8m-jxvh-vmrc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS plugin","requires_auth":"low_privilege","summary":"Authenticated users with limited permissions can bypass authorization checks in the Flex Objects plugin to escalate privileges and take over the site.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect authorization vulnerability in its Flex Objects API. FlexApiController::update() checks only the general Flex directory permission and does not apply the additional target/field/super-admin checks enforced by the dedicated Users and Groups API controllers. An authenticated account with api.access, admin.login, and users.update permissions (but without api.users.write or admin.super) can use the generic /api/v1/flex-objects/user-accounts endpoint to change a super administrator's password, or the /api/v1/flex-objects/user-groups endpoint to grant its group admin.super, resulting in full site takeover. Fixed in Flex Objects 1.4.7.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Grav through 2.0.11 Authentication Bypass via Flex Objects","id":"CVE-2026-72831","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":6,"next":{"headline":"Grav before 2.0.13 Stored XSS via quoted-attribute bypass","id":"CVE-2026-72832"},"packages":[],"prev":{"headline":"Grav API Plugin before 1.0.13 RCE via ConfigController scope bypass","id":"CVE-2026-72830"},"products":["grav","grav-plugin-flex-objects"],"published":"2026-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["getgrav","trilbymedia"]},"summary":"Authenticated users with limited permissions can bypass authorization checks in the Flex Objects plugin to escalate privileges and take over the site.","url":"https://insights.sbomify.com/CVE-2026-72831/"}