# CVE-2026-72831: Grav through 2.0.11 Authentication Bypass via Flex Objects

> Authenticated users with limited permissions can bypass authorization checks in the Flex Objects plugin to escalate privileges and take over the site.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Aug 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-7cc5-h479-2c5p, GHSA-pc8m-jxvh-vmrc

## What is CVE-2026-72831?

CVE-2026-72831 is a high-severity missing authorization vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect authorization vulnerability in its Flex Objects API. FlexApiController::update() checks only the general Flex directory permission and does not apply the additional target/field/super-admin checks enforced by the dedicated Users and Groups API controllers. An authenticated account with api.access, admin.login, and users.update permissions (but without api.users.write or admin.super) can use the generic /api/v1/flex-objects/user-accounts endpoint to change a super administrator's password, or the /api/v1/flex-objects/user-groups endpoint to grant its group admin.super, resulting in full site takeover. Fixed in Flex Objects 1.4.7.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-72831?


## How do I fix CVE-2026-72831?

No fix has been published for CVE-2026-72831 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72831 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72831 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72831 and fix it if it is affected.

What it is: CVE-2026-72831 is a high-severity missing authorization vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72831 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72831/ (Markdown: https://insights.sbomify.com/CVE-2026-72831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72831
- OSV: https://osv.dev/vulnerability/CVE-2026-72831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72831/
Summaries are generated and may contain mistakes; the official description above is the record.
