{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72832 exists.","fix":"Upgrade getgrav/grav to 2.0.13 or later.","what":"CVE-2026-72832 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-72832 and fix it if it is affected.\n\nWhat it is: CVE-2026-72832 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72832 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected from 1.5.2; fixed in 2.0.13\n- getgrav/grav (Packagist): affected from 1.5.2; fixed in 2.0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72832/ (Markdown: https://insights.sbomify.com/CVE-2026-72832/index.md)","id":"CVE-2026-72832","markdown":"https://insights.sbomify.com/CVE-2026-72832/index.md","name":"CVE-2026-72832","record":{"aliases":["GHSA-269c-h76q-8cxw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"A stored XSS vulnerability in Grav CMS allows attackers to execute arbitrary scripts in the victim's browser via crafted HTML attributes.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Grav versions from 1.5.2 through 2.0.12 contain a stored cross-site scripting vulnerability in the Security::detectXss() function (system/src/Grav/Common/Security.php). The event-handler scan is anchored at `\u003c` and uses `[^\u003e]*?`, which cannot cross the first literal `\u003e`; when a `\u003e` appears inside a quoted attribute value the browser keeps the tag open and parses a subsequent event handler (e.g. onerror), so the detector and browser disagree. A page editor without admin.super privileges can save page content such as `\u003cimg src=x title=\"\u003e\" onerror=alert(document.domain)\u003e`, which is accepted, stored, and executed in the site origin when any visitor (including unauthenticated users) views the page. Fixed in 2.0.13.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav before 2.0.13 Stored XSS via quoted-attribute bypass","id":"CVE-2026-72832","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Grav 1.0.6 through 1.0.11 Privilege Escalation via Scoped API Keys","id":"CVE-2026-72833"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.13"],"introduced":["1.5.2"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-269c-h76q-8cxw"},{"ecosystem":"Packagist","fixed":["2.0.13"],"introduced":["1.5.2"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-269c-h76q-8cxw"}],"prev":{"headline":"Grav through 2.0.11 Authentication Bypass via Flex Objects","id":"CVE-2026-72831"},"products":["grav"],"published":"2026-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["getgrav"]},"summary":"A stored XSS vulnerability in Grav CMS allows attackers to execute arbitrary scripts in the victim's browser via crafted HTML attributes.","url":"https://insights.sbomify.com/CVE-2026-72832/"}