# CVE-2026-72832: Grav before 2.0.13 Stored XSS via quoted-attribute bypass

> A stored XSS vulnerability in Grav CMS allows attackers to execute arbitrary scripts in the victim's browser via crafted HTML attributes.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Aug 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-269c-h76q-8cxw

## What is CVE-2026-72832?

CVE-2026-72832 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grav versions from 1.5.2 through 2.0.12 contain a stored cross-site scripting vulnerability in the Security::detectXss() function (system/src/Grav/Common/Security.php). The event-handler scan is anchored at `<` and uses `[^>]*?`, which cannot cross the first literal `>`; when a `>` appears inside a quoted attribute value the browser keeps the tag open and parses a subsequent event handler (e.g. onerror), so the detector and browser disagree. A page editor without admin.super privileges can save page content such as `<img src=x title=">" onerror=alert(document.domain)>`, which is accepted, stored, and executed in the site origin when any visitor (including unauthenticated users) views the page. Fixed in 2.0.13.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-72832?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | From 1.5.2 | 2.0.13 |
| `getgrav/grav` | Packagist | From 1.5.2 | 2.0.13 |

## How do I fix CVE-2026-72832?

Upgrade getgrav/grav to 2.0.13 or later.

## Is CVE-2026-72832 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72832 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72832 and fix it if it is affected.

What it is: CVE-2026-72832 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 14 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72832 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected from 1.5.2; fixed in 2.0.13
- getgrav/grav (Packagist): affected from 1.5.2; fixed in 2.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72832/ (Markdown: https://insights.sbomify.com/CVE-2026-72832/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72832
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72832
- OSV: https://osv.dev/vulnerability/CVE-2026-72832

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72832/
Summaries are generated and may contain mistakes; the official description above is the record.
