CVE-2026-72833 Grav 1.0.6 through 1.0.11 Privilege Escalation via Scoped API Keys
A scoped API key bypasses permission checks to perform super-admin write operations, allowing privilege escalation to full control.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-72833?
CVE-2026-72833 is a high-severity vulnerability in getgrav grav-plugin-api, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Grav API plugin (getgrav/grav-plugin-api) versions >= 1.0.6 and <= 1.0.11 contain a privilege escalation vulnerability. A scoped API key minted on a super-admin account bypasses its declared scope cap on four isSuperAdmin()-gated write endpoints (in GroupsController, AccountsConfigController, PreferencesController, and DashboardWidgetController). These endpoints authorize via a super-admin early-return that never invokes requirePermission()—the sole enforcement point of the scope cap—so a 'read-only'-scoped key (e.g. api.pages.read) can perform super-only write operations, including rewriting group ACL maps to grant super-admin privileges to arbitrary accounts. A leaked or delegated read-only CI/monitoring key can therefore gain full super-admin write capability. Fixed in 1.0.13.
Weakness: CWE-269
Which versions are affected by CVE-2026-72833?
How do I fix CVE-2026-72833?
No fix has been published for CVE-2026-72833 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-72833 being exploited?
There is no known exploitation of CVE-2026-72833 in the wild and no public exploit code.
Sources
Also known as GHSA-72v8-h9pq-46p7.