{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-72833 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-72833 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-72833 is a high-severity vulnerability in getgrav grav-plugin-api, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-72833 and fix it if it is affected.\n\nWhat it is: CVE-2026-72833 is a high-severity vulnerability in getgrav grav-plugin-api, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-72833 in the wild and no public exploit code.\n\nAffected product: getgrav grav-plugin-api. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72833/ (Markdown: https://insights.sbomify.com/CVE-2026-72833/index.md)","id":"CVE-2026-72833","markdown":"https://insights.sbomify.com/CVE-2026-72833/index.md","name":"CVE-2026-72833","record":{"aliases":["GHSA-72v8-h9pq-46p7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav API plugin","requires_auth":"low_privilege","summary":"A scoped API key bypasses permission checks to perform super-admin write operations, allowing privilege escalation to full control.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"The Grav API plugin (getgrav/grav-plugin-api) versions \u003e= 1.0.6 and \u003c= 1.0.11 contain a privilege escalation vulnerability. A scoped API key minted on a super-admin account bypasses its declared scope cap on four isSuperAdmin()-gated write endpoints (in GroupsController, AccountsConfigController, PreferencesController, and DashboardWidgetController). These endpoints authorize via a super-admin early-return that never invokes requirePermission()—the sole enforcement point of the scope cap—so a 'read-only'-scoped key (e.g. api.pages.read) can perform super-only write operations, including rewriting group ACL maps to grant super-admin privileges to arbitrary accounts. A leaked or delegated read-only CI/monitoring key can therefore gain full super-admin write capability. Fixed in 1.0.13.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Grav 1.0.6 through 1.0.11 Privilege Escalation via Scoped API Keys","id":"CVE-2026-72833","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"filebrowser before 2.63.19 Permission Bypass via checksum","id":"CVE-2026-72834"},"packages":[],"prev":{"headline":"Grav before 2.0.13 Stored XSS via quoted-attribute bypass","id":"CVE-2026-72832"},"products":["grav-plugin-api"],"published":"2026-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["getgrav"]},"summary":"A scoped API key bypasses permission checks to perform super-admin write operations, allowing privilege escalation to full control.","url":"https://insights.sbomify.com/CVE-2026-72833/"}