# CVE-2026-72833: Grav 1.0.6 through 1.0.11 Privilege Escalation via Scoped API Keys

> A scoped API key bypasses permission checks to perform super-admin write operations, allowing privilege escalation to full control.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Aug 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-72v8-h9pq-46p7

## What is CVE-2026-72833?

CVE-2026-72833 is a high-severity vulnerability in getgrav grav-plugin-api, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Grav API plugin (getgrav/grav-plugin-api) versions >= 1.0.6 and <= 1.0.11 contain a privilege escalation vulnerability. A scoped API key minted on a super-admin account bypasses its declared scope cap on four isSuperAdmin()-gated write endpoints (in GroupsController, AccountsConfigController, PreferencesController, and DashboardWidgetController). These endpoints authorize via a super-admin early-return that never invokes requirePermission()—the sole enforcement point of the scope cap—so a 'read-only'-scoped key (e.g. api.pages.read) can perform super-only write operations, including rewriting group ACL maps to grant super-admin privileges to arbitrary accounts. A leaked or delegated read-only CI/monitoring key can therefore gain full super-admin write capability. Fixed in 1.0.13.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-72833?


## How do I fix CVE-2026-72833?

No fix has been published for CVE-2026-72833 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72833 being exploited?

There is no known exploitation of CVE-2026-72833 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72833 and fix it if it is affected.

What it is: CVE-2026-72833 is a high-severity vulnerability in getgrav grav-plugin-api, published on 14 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72833 in the wild and no public exploit code.

Affected product: getgrav grav-plugin-api. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72833/ (Markdown: https://insights.sbomify.com/CVE-2026-72833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72833
- OSV: https://osv.dev/vulnerability/CVE-2026-72833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72833/
Summaries are generated and may contain mistakes; the official description above is the record.
