# CVE-2026-72871: Dokploy: Unauthenticated Git Provider Injection via GitHub OAuth Callback

> An unauthenticated attacker can inject malicious GitHub provider configurations into other organizations via the OAuth callback endpoint.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** GHSA-g9pp-xcf2-ph7x

## What is CVE-2026-72871?

CVE-2026-72871 is a high-severity missing authorization vulnerability in dokploy, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dokploy is a free, self-hostable Platform as a Service (PaaS). Prior to 0.29.13, the unauthenticated /api/providers/github/setup route in apps/dokploy/pages/api/providers/github/setup.ts trusts gh_init organizationId and userId values from the state parameter and calls createGithub in packages/server/src/services/github.ts, allowing an attacker to insert a GitHub App provider containing client_secret, webhook_secret, and PEM private key material into another organization. This issue is fixed in version 0.29.13.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-72871?


## How do I fix CVE-2026-72871?

No fix has been published for CVE-2026-72871 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72871 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72871 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72871 and fix it if it is affected.

What it is: CVE-2026-72871 is a high-severity missing authorization vulnerability in dokploy, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72871 exists.

Affected product: dokploy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72871/ (Markdown: https://insights.sbomify.com/CVE-2026-72871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72871
- OSV: https://osv.dev/vulnerability/CVE-2026-72871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72871/
Summaries are generated and may contain mistakes; the official description above is the record.
