# CVE-2026-72881: Dokploy: Command Injection via database credentials in backup/restore commands

> An authenticated administrator can execute arbitrary commands via crafted database credentials in backup/restore operations, exposing data and enabling container escape.

- **Severity:** Medium 6.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** GHSA-qc73-mp78-4833

## What is CVE-2026-72881?

CVE-2026-72881 is a medium-severity command injection vulnerability in dokploy, published on 10 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Dokploy is a free, self-hostable Platform as a Service (PaaS). Prior to 0.29.13, database backup and restore command builders in packages/server/src/utils/backups/utils.ts and packages/server/src/utils/restore/utils.ts interpolate database names, usernames, and passwords into nested shell command strings passed to child_process.exec(). An authenticated administrator with permission to create databases and configure backups can use crafted database configuration fields to execute arbitrary commands inside PostgreSQL, MariaDB, MySQL, MongoDB, or LibSQL containers, exposing database data and credentials and potentially enabling escape when a container is overprivileged. This issue is fixed in version 0.29.13.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-72881?


## How do I fix CVE-2026-72881?

No fix has been published for CVE-2026-72881 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72881 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72881 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72881 and fix it if it is affected.

What it is: CVE-2026-72881 is a medium-severity command injection vulnerability in dokploy, published on 10 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72881 exists.

Affected product: dokploy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72881/ (Markdown: https://insights.sbomify.com/CVE-2026-72881/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72881
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72881
- OSV: https://osv.dev/vulnerability/CVE-2026-72881

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72881/
Summaries are generated and may contain mistakes; the official description above is the record.
