# CVE-2026-72884: Dokploy: Command Injection via Compose Custom Command

> An authenticated user can inject shell metacharacters into Compose service commands to execute arbitrary code on the Dokploy host.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** GHSA-qh6h-669j-77rw

## What is CVE-2026-72884?

CVE-2026-72884 is a high-severity command injection vulnerability in dokploy, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Dokploy is a free, self-hostable Platform as a Service (PaaS). Prior to 0.29.13, sanitizeCommand in packages/server/src/utils/builders/compose.ts only trims whitespace and strips surrounding quotes from compose.command before exportEnvCommand and docker command interpolation, allowing an authenticated user who can update a Compose service to inject shell metacharacters and execute arbitrary commands on the Dokploy host. This issue is fixed in version 0.29.13.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-72884?


## How do I fix CVE-2026-72884?

No fix has been published for CVE-2026-72884 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72884 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72884 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72884 and fix it if it is affected.

What it is: CVE-2026-72884 is a high-severity command injection vulnerability in dokploy, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72884 exists.

Affected product: dokploy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72884/ (Markdown: https://insights.sbomify.com/CVE-2026-72884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72884
- OSV: https://osv.dev/vulnerability/CVE-2026-72884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72884/
Summaries are generated and may contain mistakes; the official description above is the record.
