# CVE-2026-72904: Firecrawl: Arbitrary file read via JSON Schema $ref expansion


- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** GHSA-3p54-jg6f-68r8

## What is CVE-2026-72904?

CVE-2026-72904 is a critical vulnerability in firecrawl, published on 10 Aug 2026. 

### Official description

Firecrawl turns entire websites into LLM-ready markdown or structured data. Prior to 2.11.32, a critical arbitrary file read vulnerability exists in Firecrawl's extraction functionality due to unsafe schema dereferencing of user-supplied JSON schemas in apps/api/src/lib/extract/helpers/dereference-schema.ts. The affected code invokes the json-schema-ref-parser dependency with default resolver settings, allowing external and local file references to be resolved during schema processing. An authenticated attacker can supply a malicious schema containing a $ref within default, const, or enum fields that are not traversed by AJV validation. By triggering a dereference error, file contents from the extract worker filesystem may be included in persisted error messages returned through the extraction API, enabling arbitrary file reads and SSRF against internal or external HTTP endpoints. This issue is fixed in version 2.11.32.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code), CWE-94 (Improper Control of Generation of Code), CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-72904?


## How do I fix CVE-2026-72904?

No fix has been published for CVE-2026-72904 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72904 being exploited?

There is no known exploitation of CVE-2026-72904 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72904 and fix it if it is affected.

What it is: CVE-2026-72904 is a critical vulnerability in firecrawl, published on 10 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-72904 in the wild and no public exploit code.

Affected product: firecrawl. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72904/ (Markdown: https://insights.sbomify.com/CVE-2026-72904/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72904
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72904
- OSV: https://osv.dev/vulnerability/CVE-2026-72904

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72904/
Summaries are generated and may contain mistakes; the official description above is the record.
