# CVE-2026-72907: ERPNext: Broken Access Control on certain endpoint

> Authenticated limited users can create unauthorized accounting records due to missing permission checks, compromising financial data integrity.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-94v6-784v-24q5

## What is CVE-2026-72907?

CVE-2026-72907 is a medium-severity missing authorization vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.111.0 and 16.22.0, the add_ac function in erpnext/accounts/utils.py accepts the ignore_permissions argument without enforcing Account create permission, allowing an authenticated limited user to create unauthorized accounting master records and affect financial data integrity and audit trails. This issue is fixed in versions 15.111.0 and 16.22.0.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-72907?


## How do I fix CVE-2026-72907?

No fix has been published for CVE-2026-72907 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72907 being exploited?

There is no known exploitation of CVE-2026-72907 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72907 and fix it if it is affected.

What it is: CVE-2026-72907 is a medium-severity missing authorization vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72907 in the wild and no public exploit code.

Affected product: frappe erpnext. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72907/ (Markdown: https://insights.sbomify.com/CVE-2026-72907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72907
- OSV: https://osv.dev/vulnerability/CVE-2026-72907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72907/
Summaries are generated and may contain mistakes; the official description above is the record.
