CVE-2026-72908 ERPNext: Possibility of SQL injection due to missing validation

Medium 6.5 Published Updated

An authenticated low-privilege user can inject SQL via the get_tax_template function to extract sensitive information from the ERPNext database.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-72908?

CVE-2026-72908 is a medium-severity SQL injection vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.109.0 and 16.20.0, the get_tax_template function in erpnext/accounts/doctype/tax_rule/tax_rule.py constructs an SQL WHERE clause from request-influenced posting_date and args values, allowing an authenticated low-privilege user to inject SQL and extract sensitive information. This issue is fixed in versions 15.109.0 and 16.20.0.

Weakness: CWE-89

Which versions are affected by CVE-2026-72908?

How do I fix CVE-2026-72908?

No fix has been published for CVE-2026-72908 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-72908 being exploited?

There is no known exploitation of CVE-2026-72908 in the wild and no public exploit code.

Sources

Also known as GHSA-grhp-m55m-63f8.

Is CVE-2026-72908 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free