# CVE-2026-72909: ERPNext: Broken Access Control on certain endpoints

> Authenticated users can bypass permission checks to read unauthorized cross-company financial data in Accounts Receivable and Payable reports.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** GHSA-p577-cxv9-h82f

## What is CVE-2026-72909?

CVE-2026-72909 is a high-severity missing authorization vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.112.0 and 16.23.0, the ReceivablePayableReport prepare_conditions path in erpnext/accounts/report/accounts_receivable/accounts_receivable.py does not apply Customer and Supplier user permissions to the Payment Ledger Entry dynamic-link party field, allowing any authenticated user to read unauthorized cross-company financial data in Accounts Receivable and Accounts Payable reports. This issue is fixed in versions 15.112.0 and 16.23.0.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-72909?


## How do I fix CVE-2026-72909?

No fix has been published for CVE-2026-72909 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72909 being exploited?

There is no known exploitation of CVE-2026-72909 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72909 and fix it if it is affected.

What it is: CVE-2026-72909 is a high-severity missing authorization vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72909 in the wild and no public exploit code.

Affected product: frappe erpnext. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72909/ (Markdown: https://insights.sbomify.com/CVE-2026-72909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72909
- OSV: https://osv.dev/vulnerability/CVE-2026-72909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72909/
Summaries are generated and may contain mistakes; the official description above is the record.
