CVE-2026-72910 ERPNext: Unauthorised modification of master data due to missing validation

High 7.1 Published Updated

Authenticated limited users can modify protected master data in ERPNext due to missing write permission checks in specific accounting functions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-72910?

CVE-2026-72910 is a high-severity missing authorization vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.112.0 and 16.22.0, the merge_account, pause_job_for_doc, trigger_job_for_doc, change_release_date, and update_cost_center functions across erpnext/accounts/doctype/account/account.py, erpnext/accounts/doctype/process_payment_reconciliation/process_payment_reconciliation.py, erpnext/accounts/doctype/purchase_invoice/purchase_invoice.py, and erpnext/accounts/utils.py omit required write permission checks, allowing authenticated limited users to modify protected data beyond their roles. This issue is fixed in versions 15.112.0 and 16.22.0.

Weakness: CWE-862

Which versions are affected by CVE-2026-72910?

How do I fix CVE-2026-72910?

No fix has been published for CVE-2026-72910 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-72910 being exploited?

There is no known exploitation of CVE-2026-72910 in the wild and no public exploit code.

Sources

Also known as GHSA-qpvh-75wh-j645.

Is CVE-2026-72910 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free