CVE-2026-72911 ERPNext: Possibility of server-side template injection due to missing validation

Critical 9.9 Published Updated

Authenticated users can inject template expressions to execute arbitrary server-side code and read application data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-72911?

CVE-2026-72911 is a critical code injection vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.118.0 and 16.29.0, the validate_template and render_template calls in erpnext/accounts/doctype/process_statement_of_accounts/process_statement_of_accounts.py render subject, body, and pdf_name fields with unrestricted globals including frappe.utils, allowing an authenticated user with a common operational role to inject template expressions, execute arbitrary server-side code, and read data across the application. This issue is fixed in versions 15.118.0 and 16.29.0.

Weakness: CWE-1336

Which versions are affected by CVE-2026-72911?

How do I fix CVE-2026-72911?

No fix has been published for CVE-2026-72911 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-72911 being exploited?

There is no known exploitation of CVE-2026-72911 in the wild and no public exploit code.

Sources

Also known as GHSA-qq49-v74j-hjh7.

Is CVE-2026-72911 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free