# CVE-2026-72911: ERPNext: Possibility of server-side template injection due to missing validation

> Authenticated users can inject template expressions to execute arbitrary server-side code and read application data.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-qq49-v74j-hjh7

## What is CVE-2026-72911?

CVE-2026-72911 is a critical code injection vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.118.0 and 16.29.0, the validate_template and render_template calls in erpnext/accounts/doctype/process_statement_of_accounts/process_statement_of_accounts.py render subject, body, and pdf_name fields with unrestricted globals including frappe.utils, allowing an authenticated user with a common operational role to inject template expressions, execute arbitrary server-side code, and read data across the application. This issue is fixed in versions 15.118.0 and 16.29.0.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-72911?


## How do I fix CVE-2026-72911?

No fix has been published for CVE-2026-72911 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72911 being exploited?

There is no known exploitation of CVE-2026-72911 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72911 and fix it if it is affected.

What it is: CVE-2026-72911 is a critical code injection vulnerability in frappe erpnext, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72911 in the wild and no public exploit code.

Affected product: frappe erpnext. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72911/ (Markdown: https://insights.sbomify.com/CVE-2026-72911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72911
- OSV: https://osv.dev/vulnerability/CVE-2026-72911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72911/
Summaries are generated and may contain mistakes; the official description above is the record.
