# CVE-2026-72912: CyberChef’s pretty-recipe parser vulnerable to client-side ReDoS / CPU exhaustion when parsing a malformed #recipe= URL


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-w74r-jxjh-gwr6

## What is CVE-2026-72912?

CVE-2026-72912 is a medium-severity vulnerability in gchq CyberChef, published on 10 Aug 2026. 

### Official description

CyberChef is a web app for encryption, encoding, compression, and data analysis. Prior to 11.3.0, CyberChef's pretty-recipe parser in src/core/Utils.mjs can exhaust client-side CPU when a malformed #recipe= URL fragment containing a large number of unmatched quote characters reaches Utils.parseRecipeConfig(). The function synchronously applies a complex global regular expression that may perform heavy backtracking before rejecting the input, causing the victim's browser tab to freeze during startup for seconds or longer. No code execution, data exfiltration, or privilege escalation occurs. This issue is fixed in version 11.3.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-72912?


## How do I fix CVE-2026-72912?

No fix has been published for CVE-2026-72912 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72912 being exploited?

There is no known exploitation of CVE-2026-72912 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72912 and fix it if it is affected.

What it is: CVE-2026-72912 is a medium-severity vulnerability in gchq CyberChef, published on 10 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-72912 in the wild and no public exploit code.

Affected product: gchq CyberChef. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72912/ (Markdown: https://insights.sbomify.com/CVE-2026-72912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72912
- OSV: https://osv.dev/vulnerability/CVE-2026-72912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72912/
Summaries are generated and may contain mistakes; the official description above is the record.
