{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72913 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-72913 is a high-severity command injection vulnerability in kovidgoyal kitty, published on 10 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-72913 and fix it if it is affected.\n\nWhat it is: CVE-2026-72913 is a high-severity command injection vulnerability in kovidgoyal kitty, published on 10 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72913 exists.\n\nAffected product: kovidgoyal kitty. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72913/ (Markdown: https://insights.sbomify.com/CVE-2026-72913/index.md)","id":"CVE-2026-72913","markdown":"https://insights.sbomify.com/CVE-2026-72913/index.md","name":"CVE-2026-72913","record":{"aliases":["DEBIAN-CVE-2026-72913","GHSA-ccp2-q4v6-rw94","UBUNTU-CVE-2026-72913"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Kitty terminal emulator","requires_auth":"none","summary":"Attackers can execute arbitrary commands in the child shell by chaining DCS escape sequences when a user displays untrusted terminal data.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-93","name":"Improper Neutralization of CRLF Sequences"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"}],"description":"Kitty is a cross-platform GPU based terminal. Prior to 0.48.2, the @kitty-echo and @kitty-ssh DCS handlers in kitty/window.py write unauthenticated data to the child shell's stdin, where handle_remote_echo accepts printable shell command characters and handle_remote_ssh calls get_ssh_data in kittens/ssh/utils.py, which emits a newline; chaining the handlers can execute attacker-controlled commands when a user displays untrusted terminal data. This issue is fixed in version 0.48.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Kitty: Command injection into the child shell via chained @kitty-echo + @kitty-ssh DCS escape sequences","id":"CVE-2026-72913","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Mastodon: Exhausting data by an unauthenticated request to the admin retention API","id":"CVE-2026-72914"},"packages":[],"prev":{"headline":"CyberChef’s pretty-recipe parser vulnerable to client-side ReDoS / CPU exhaustion when parsing a malformed #recipe= URL","id":"CVE-2026-72912"},"products":["kitty"],"published":"2026-08-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-11","vendors":["kovidgoyal"]},"summary":"Attackers can execute arbitrary commands in the child shell by chaining DCS escape sequences when a user displays untrusted terminal data.","url":"https://insights.sbomify.com/CVE-2026-72913/"}