# CVE-2026-72913: Kitty: Command injection into the child shell via chained @kitty-echo + @kitty-ssh DCS escape sequences

> Attackers can execute arbitrary commands in the child shell by chaining DCS escape sequences when a user displays untrusted terminal data.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-72913, GHSA-ccp2-q4v6-rw94, UBUNTU-CVE-2026-72913

## What is CVE-2026-72913?

CVE-2026-72913 is a high-severity command injection vulnerability in kovidgoyal kitty, published on 10 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Kitty is a cross-platform GPU based terminal. Prior to 0.48.2, the @kitty-echo and @kitty-ssh DCS handlers in kitty/window.py write unauthenticated data to the child shell's stdin, where handle_remote_echo accepts printable shell command characters and handle_remote_ssh calls get_ssh_data in kittens/ssh/utils.py, which emits a newline; chaining the handlers can execute attacker-controlled commands when a user displays untrusted terminal data. This issue is fixed in version 0.48.2.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences), CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2026-72913?


## How do I fix CVE-2026-72913?

Upgrade to a fixed version.

## Is CVE-2026-72913 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72913 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72913 and fix it if it is affected.

What it is: CVE-2026-72913 is a high-severity command injection vulnerability in kovidgoyal kitty, published on 10 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72913 exists.

Affected product: kovidgoyal kitty. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72913/ (Markdown: https://insights.sbomify.com/CVE-2026-72913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72913
- OSV: https://osv.dev/vulnerability/CVE-2026-72913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72913/
Summaries are generated and may contain mistakes; the official description above is the record.
