CVE-2026-72914 Mastodon: Exhausting data by an unauthenticated request to the admin retention API
Unauthenticated attackers can exhaust server resources by triggering expensive SQL queries via admin retention API endpoints before authorization checks occur.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72914?
CVE-2026-72914 is a high-severity denial of service vulnerability in mastodon, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mastodon is a free, open-source social network server based on ActivityPub. Prior to 4.4.21, 4.5.14, 4.6.4, and 4.7.0-beta.1, the administrative statistics endpoints handled by Api::V1::Admin::MeasuresController and Api::V1::Admin::RetentionController checked authorization only after beginning expensive calculations. Anonymous callers could submit keys, start_at, and end_at parameters that caused long-running SQL queries in Admin::Metrics::Measure, Admin::Metrics::Retention, and Admin::Metrics::Dimension::BaseDimension, allowing repeated requests to exhaust server resources. This issue is fixed in versions 4.4.21, 4.5.14, 4.6.4, and 4.7.0-beta.1.
Which versions are affected by CVE-2026-72914?
1 open source package ship an affected version, including mastodon.
| Package | Affected | Fixed in |
|---|---|---|
mastodon Bitnami | All versions | 4.4.21, 4.5.14, 4.6.4 |
How do I fix CVE-2026-72914?
Upgrade mastodon to a fixed version for your release line: 4.4.21, 4.5.14 or 4.6.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-72914 being exploited?
There is no known exploitation of CVE-2026-72914 in the wild and no public exploit code.
Sources
Also known as BIT-mastodon-2026-72914, GHSA-7jvv-fhmg-wpfw.