# CVE-2026-72914: Mastodon: Exhausting data by an unauthenticated request to the admin retention API

> Unauthenticated attackers can exhaust server resources by triggering expensive SQL queries via admin retention API endpoints before authorization checks occur.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** BIT-mastodon-2026-72914, GHSA-7jvv-fhmg-wpfw

## What is CVE-2026-72914?

CVE-2026-72914 is a high-severity denial of service vulnerability in mastodon, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mastodon is a free, open-source social network server based on ActivityPub. Prior to 4.4.21, 4.5.14, 4.6.4, and 4.7.0-beta.1, the administrative statistics endpoints handled by Api::V1::Admin::MeasuresController and Api::V1::Admin::RetentionController checked authorization only after beginning expensive calculations. Anonymous callers could submit keys, start_at, and end_at parameters that caused long-running SQL queries in Admin::Metrics::Measure, Admin::Metrics::Retention, and Admin::Metrics::Dimension::BaseDimension, allowing repeated requests to exhaust server resources. This issue is fixed in versions 4.4.21, 4.5.14, 4.6.4, and 4.7.0-beta.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2026-72914?

1 open source package ship an affected version, including mastodon.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | All versions | 4.4.21, 4.5.14, 4.6.4 |

## How do I fix CVE-2026-72914?

Upgrade mastodon to a fixed version for your release line: 4.4.21, 4.5.14 or 4.6.4.

## Is CVE-2026-72914 being exploited?

There is no known exploitation of CVE-2026-72914 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72914 and fix it if it is affected.

What it is: CVE-2026-72914 is a high-severity denial of service vulnerability in mastodon, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72914 in the wild and no public exploit code.

Affected packages and fixed versions:
- mastodon (Bitnami): affected all versions; fixed in 4.4.21, 4.5.14, 4.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72914/ (Markdown: https://insights.sbomify.com/CVE-2026-72914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72914
- OSV: https://osv.dev/vulnerability/CVE-2026-72914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72914/
Summaries are generated and may contain mistakes; the official description above is the record.
