# CVE-2026-72915: Mastodon: Personally-identifying information disclosure due to incorrect access control validation

> Logged-in users can access other users' email and IP addresses due to incorrect access control in the admin collections controller.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** BIT-mastodon-2026-72915, GHSA-hx34-2pfw-2qfj

## What is CVE-2026-72915?

CVE-2026-72915 is a high-severity vulnerability in mastodon, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mastodon is a free, open-source social network server based on ActivityPub. From 4.6.0-beta.1 until 4.6.4 and 4.7.0-beta.1, any logged-in local user could use the show action in app/controllers/admin/collections_controller.rb to access personally identifying information about another local user in a collection because the controller used the general collection policy instead of the admin collection policy namespace. The exposed data included the other user's current email address and last-used IP address. This issue is fixed in versions 4.6.4 and 4.7.0-beta.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-72915?

1 open source package ship an affected version, including mastodon.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | From 4.6.0 | 4.6.4 |

## How do I fix CVE-2026-72915?

Upgrade mastodon to 4.6.4 or later.

## Is CVE-2026-72915 being exploited?

There is no known exploitation of CVE-2026-72915 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72915 and fix it if it is affected.

What it is: CVE-2026-72915 is a high-severity vulnerability in mastodon, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72915 in the wild and no public exploit code.

Affected packages and fixed versions:
- mastodon (Bitnami): affected from 4.6.0; fixed in 4.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72915/ (Markdown: https://insights.sbomify.com/CVE-2026-72915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72915
- OSV: https://osv.dev/vulnerability/CVE-2026-72915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72915/
Summaries are generated and may contain mistakes; the official description above is the record.
