# CVE-2026-72922: AutoGPT: Webhook provider path confusion bypasses generic webhook secret verification

> Attackers can bypass webhook secret verification to execute arbitrary AI agent workflows as the owner, requiring an upgrade to AutoGPT.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-349p-3c3r-8mjr

## What is CVE-2026-72922?

CVE-2026-72922 is a high-severity authentication bypass vulnerability in Significant-Gravitas AutoGPT, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.70, AutoGPT's autogpt_platform/backend/backend/api/features/integrations/router.py webhook_ingress_generic route selected get_webhook_manager(provider) from the untrusted provider URL segment without verifying webhook.provider, allowing a request to /compass/webhooks/{webhook_id}/ingress to use CompassWebhookManager's inherited no-op BaseWebhooksManager.verify_signature instead of GenericWebhooksManager.verify_signature, bypass X-Webhook-Secret for a configured secret_token, and execute a generic webhook graph as its owner. This issue is fixed in version 0.6.70.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-72922?


## How do I fix CVE-2026-72922?

No fix has been published for CVE-2026-72922 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-72922 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72922 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72922 and fix it if it is affected.

What it is: CVE-2026-72922 is a high-severity authentication bypass vulnerability in Significant-Gravitas AutoGPT, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72922 exists.

Affected product: Significant-Gravitas AutoGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72922/ (Markdown: https://insights.sbomify.com/CVE-2026-72922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72922
- OSV: https://osv.dev/vulnerability/CVE-2026-72922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72922/
Summaries are generated and may contain mistakes; the official description above is the record.
