CVE-2026-72923 Microsoft.OpenApi.YamlReader vulnerable to denial of service via YAML alias expansion

High 7.5 Published Updated

Attackers can cause denial of service via memory exhaustion by parsing crafted YAML documents with nested anchors and aliases in the OpenAPI.NET SDK.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-72923?

CVE-2026-72923 is a high-severity denial of service vulnerability in microsoft OpenAPI.NET, published on 8 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The OpenAPI.NET SDK contains a useful object model for OpenAPI documents in .NET along with common serializers to extract raw OpenAPI JSON and YAML documents from the model. In Microsoft.OpenApi.Readers versions before 1.6.30 and Microsoft.OpenApi.YamlReader from 2.0.0-preview.11 through 2.11.0 and 3.0.0 through 3.9.0, parsing a YAML OpenAPI document with nested anchors and aliases can consume uncontrolled memory. SharpYaml represents aliases as shared nodes in a small directed acyclic graph, but conversion to independent OpenAPI or System.Text.Json.Nodes.JsonNode trees duplicates every aliased path; without a node-count or nesting-depth limit, N nested anchors referenced k times can require k^N materialized nodes and terminate the process through an out-of-memory condition. The fixed readers bound materialization to 5,000,000 nodes and a nesting depth of 64 by default and report an OpenApiDiagnostic error when a limit is exceeded. This vulnerability is fixed in Microsoft.OpenApi.Readers 1.6.30 and Microsoft.OpenApi.YamlReader 2.12.0 and 3.10.0.

Weakness: CWE-400

Which versions are affected by CVE-2026-72923?

6 open source packages ship an affected version, including Microsoft.OpenApi.YamlReader and Microsoft.OpenApi.Readers.

PackageAffectedFixed in
Microsoft.OpenApi.YamlReader NuGetFrom 2.0.0-preview.112.12.0
Microsoft.OpenApi.YamlReader NuGetFrom 2.0.0-preview.112.12.0
Microsoft.OpenApi.YamlReader NuGetFrom 3.0.03.10.0
Microsoft.OpenApi.YamlReader NuGetFrom 3.0.03.10.0
Microsoft.OpenApi.Readers NuGetAll versions1.6.30
Microsoft.OpenApi.Readers NuGetAll versions1.6.30

How do I fix CVE-2026-72923?

Upgrade Microsoft.OpenApi.YamlReader to a fixed version for your release line: 2.12.0 or 3.10.0.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-72923 being exploited?

There is no known exploitation of CVE-2026-72923 in the wild and no public exploit code.

Sources

Also known as GHSA-7pxr-59rr-hqj2.

Is CVE-2026-72923 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free