# CVE-2026-72923: Microsoft.OpenApi.YamlReader vulnerable to denial of service via YAML alias expansion

> Attackers can cause denial of service via memory exhaustion by parsing crafted YAML documents with nested anchors and aliases in the OpenAPI.NET SDK.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 14 Oct 2026
- **Also known as:** GHSA-7pxr-59rr-hqj2

## What is CVE-2026-72923?

CVE-2026-72923 is a high-severity denial of service vulnerability in microsoft OpenAPI.NET, published on 8 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OpenAPI.NET SDK contains a useful object model for OpenAPI documents in .NET along with common serializers to extract raw OpenAPI JSON and YAML documents from the model. In Microsoft.OpenApi.Readers versions before 1.6.30 and Microsoft.OpenApi.YamlReader from 2.0.0-preview.11 through 2.11.0 and 3.0.0 through 3.9.0, parsing a YAML OpenAPI document with nested anchors and aliases can consume uncontrolled memory. SharpYaml represents aliases as shared nodes in a small directed acyclic graph, but conversion to independent OpenAPI or System.Text.Json.Nodes.JsonNode trees duplicates every aliased path; without a node-count or nesting-depth limit, N nested anchors referenced k times can require k^N materialized nodes and terminate the process through an out-of-memory condition. The fixed readers bound materialization to 5,000,000 nodes and a nesting depth of 64 by default and report an OpenApiDiagnostic error when a limit is exceeded. This vulnerability is fixed in Microsoft.OpenApi.Readers 1.6.30 and Microsoft.OpenApi.YamlReader 2.12.0 and 3.10.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-72923?

6 open source packages ship an affected version, including Microsoft.OpenApi.YamlReader and Microsoft.OpenApi.Readers.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.OpenApi.YamlReader` | NuGet | From 2.0.0-preview.11 | 2.12.0 |
| `Microsoft.OpenApi.YamlReader` | NuGet | From 2.0.0-preview.11 | 2.12.0 |
| `Microsoft.OpenApi.YamlReader` | NuGet | From 3.0.0 | 3.10.0 |
| `Microsoft.OpenApi.YamlReader` | NuGet | From 3.0.0 | 3.10.0 |
| `Microsoft.OpenApi.Readers` | NuGet | All versions | 1.6.30 |
| `Microsoft.OpenApi.Readers` | NuGet | All versions | 1.6.30 |

## How do I fix CVE-2026-72923?

Upgrade Microsoft.OpenApi.YamlReader to a fixed version for your release line: 2.12.0 or 3.10.0.

## Is CVE-2026-72923 being exploited?

There is no known exploitation of CVE-2026-72923 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72923 and fix it if it is affected.

What it is: CVE-2026-72923 is a high-severity denial of service vulnerability in microsoft OpenAPI.NET, published on 8 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72923 in the wild and no public exploit code.

Affected packages and fixed versions:
- Microsoft.OpenApi.YamlReader (NuGet): affected from 2.0.0-preview.11; fixed in 2.12.0
- Microsoft.OpenApi.YamlReader (NuGet): affected from 2.0.0-preview.11; fixed in 2.12.0
- Microsoft.OpenApi.YamlReader (NuGet): affected from 3.0.0; fixed in 3.10.0
- Microsoft.OpenApi.YamlReader (NuGet): affected from 3.0.0; fixed in 3.10.0
- Microsoft.OpenApi.Readers (NuGet): affected all versions; fixed in 1.6.30
- Microsoft.OpenApi.Readers (NuGet): affected all versions; fixed in 1.6.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72923/ (Markdown: https://insights.sbomify.com/CVE-2026-72923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72923
- OSV: https://osv.dev/vulnerability/CVE-2026-72923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72923/
Summaries are generated and may contain mistakes; the official description above is the record.
