{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-72924 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-72924 is a low-severity vulnerability in cli, published on 25 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-72924 and fix it if it is affected.\n\nWhat it is: CVE-2026-72924 is a low-severity vulnerability in cli, published on 25 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-72924 in the wild and no public exploit code.\n\nAffected product: cli. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72924/ (Markdown: https://insights.sbomify.com/CVE-2026-72924/index.md)","id":"CVE-2026-72924","markdown":"https://insights.sbomify.com/CVE-2026-72924/index.md","name":"CVE-2026-72924","record":{"aliases":["AZL-98198","DEBIAN-CVE-2026-72924","GHSA-vfhh-p7hm-pxfh","UBUNTU-CVE-2026-72924"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GitHub CLI","requires_auth":"low_privilege","summary":"GitHub CLI binds port forwarding to all interfaces by default, exposing local services to network-adjacent attackers.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-1327","name":"Binding to an Unrestricted IP Address"}],"description":"GitHub CLI (gh) is GitHub's official command line tool. Versions 2.28.0 through 2.97.0 bind the local listener created by gh codespace ports forward to all available network interfaces by default. While port forwarding is active, a service in a Codespace can therefore become reachable through the user's non-loopback local IP addresses by other hosts that can route to the user's machine. This behavior does not change the GitHub-side visibility of the Codespaces port. Instead, it exposes the forwarded service through a wildcard-bound listener on the user's local machine, even when the source Codespaces port remains private. Exploitation requires a network-adjacent attacker to reach the victim's machine while forwarding is active. This issue is fixed in version 2.98.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GitHub CLI: `gh codespace ports forward` exposes forwarded services on all network interfaces by default","id":"CVE-2026-72924","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"misconfiguration","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"SWC HTML minifier may allow script element breakout when minifying embedded JSON","id":"CVE-2026-72925"},"packages":[],"prev":{"headline":"Microsoft.OpenApi.YamlReader vulnerable to denial of service via YAML alias expansion","id":"CVE-2026-72923"},"products":["cli"],"published":"2026-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-26","vendors":["cli"]},"summary":"GitHub CLI binds port forwarding to all interfaces by default, exposing local services to network-adjacent attackers.","url":"https://insights.sbomify.com/CVE-2026-72924/"}