# CVE-2026-7303: Xuxueli xxl-job Execution Log JobLogController.java logDetailCat resource injection

> Remote attackers can manipulate log identifiers to access unauthorized execution logs via improper resource control in xxl-job.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2026
- **Updated:** 29 Apr 2026
- **Also known as:** GHSA-gw2x-mfwr-h46p

## What is CVE-2026-7303?

CVE-2026-7303 is a medium-severity path traversal vulnerability in Xuxueli xxl-job, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A security flaw has been discovered in Xuxueli xxl-job up to 3.3.2. Impacted is the function logDetailCat of the file xxl-job-admin/src/main/java/com/xxl/job/admin/controller/biz/JobLogController.java of the component Execution Log Handler. The manipulation of the argument logId results in improper control of resource identifiers. The attack may be performed from remote. This attack is characterized by high complexity. The exploitability is considered difficult. The exploit has been released to the public and may be used for attacks. Upgrading to version 3.4.0 is recommended to address this issue. The patch is identified as d24e4ccd6073cc75305e1d3b9c29bc8db7437e7a. It is suggested to upgrade the affected component.

Weakness: CWE-99 (Improper Control of Resource Identifiers)

## Which versions are affected by CVE-2026-7303?

2 open source packages ship an affected version, including com.xuxueli:xxl-job-admin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.xuxueli:xxl-job-admin` | Maven | All versions | 3.4.0 |
| `com.xuxueli:xxl-job-admin` | Maven | All versions | 3.4.0 |

## How do I fix CVE-2026-7303?

Upgrade com.xuxueli:xxl-job-admin to 3.4.0 or later.

## Is CVE-2026-7303 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7303 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7303 and fix it if it is affected.

What it is: CVE-2026-7303 is a medium-severity path traversal vulnerability in Xuxueli xxl-job, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7303 exists.

Affected packages and fixed versions:
- com.xuxueli:xxl-job-admin (Maven): affected all versions; fixed in 3.4.0
- com.xuxueli:xxl-job-admin (Maven): affected all versions; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7303/ (Markdown: https://insights.sbomify.com/CVE-2026-7303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7303
- OSV: https://osv.dev/vulnerability/CVE-2026-7303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7303/
Summaries are generated and may contain mistakes; the official description above is the record.
