# CVE-2026-73035: npm-check-updates 23.0.2 Terminal Injection via Unsanitized Escape Sequences

> Attackers can inject terminal escape sequences via package metadata, allowing output manipulation when developers use specific formatting options.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** GHSA-xm8c-hvjf-c5q9

## What is CVE-2026-73035?

CVE-2026-73035 is a medium-severity vulnerability in raineorshine npm-check-updates, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

npm-check-updates through 23.0.2, fixed in commit b554b84, contains a terminal escape sequence injection vulnerability that allows an attacker to embed arbitrary terminal control characters in a dependency's package.json homepage or repository URL fields. When a developer runs ncu with the --format homepage or --format repo option, unfiltered escape sequences are written directly to the terminal, enabling malicious output manipulation or other terminal-dependent effects.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2026-73035?


## How do I fix CVE-2026-73035?

No fix has been published for CVE-2026-73035 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73035 being exploited?

There is no known exploitation of CVE-2026-73035 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73035 and fix it if it is affected.

What it is: CVE-2026-73035 is a medium-severity vulnerability in raineorshine npm-check-updates, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-73035 in the wild and no public exploit code.

Affected product: raineorshine npm-check-updates. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73035/ (Markdown: https://insights.sbomify.com/CVE-2026-73035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73035
- OSV: https://osv.dev/vulnerability/CVE-2026-73035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73035/
Summaries are generated and may contain mistakes; the official description above is the record.
