# CVE-2026-73062: Scriban 3.0.0 through 7.2.0 Denial of Service via Array Multiplication

> Attackers can cause resource exhaustion and denial of service by supplying large integer multipliers in templates, affecting applications using the Scriban library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-q6rr-fm2g-g5x8, GHSA-q84q-h76q-mqp7

## What is CVE-2026-73062?

CVE-2026-73062 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Scriban versions 3.0.0 through 7.2.0 contain a denial of service vulnerability in the array multiplication operator that allocates memory without enforcing LoopLimit or overflow-safe arithmetic checks. Attackers can supply a large integer multiplier in a template to force multi-gigabyte memory allocations, causing resource exhaustion and availability degradation.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-73062?

4 open source packages ship an affected version, including Scriban and Scriban.Signed.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Scriban` | NuGet | From 3.0.0 | 7.2.1 |
| `Scriban` | NuGet | From 3.0.0 | 7.2.1 |
| `Scriban.Signed` | NuGet | From 3.0.0 | 7.2.1 |
| `Scriban.Signed` | NuGet | From 3.0.0 | 7.2.1 |

## How do I fix CVE-2026-73062?

Upgrade Scriban to 7.2.1 or later.

## Is CVE-2026-73062 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73062 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73062 and fix it if it is affected.

What it is: CVE-2026-73062 is a high-severity denial of service vulnerability in scriban, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73062 exists.

Affected packages and fixed versions:
- Scriban (NuGet): affected from 3.0.0; fixed in 7.2.1
- Scriban (NuGet): affected from 3.0.0; fixed in 7.2.1
- Scriban.Signed (NuGet): affected from 3.0.0; fixed in 7.2.1
- Scriban.Signed (NuGet): affected from 3.0.0; fixed in 7.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73062/ (Markdown: https://insights.sbomify.com/CVE-2026-73062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73062
- OSV: https://osv.dev/vulnerability/CVE-2026-73062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73062/
Summaries are generated and may contain mistakes; the official description above is the record.
