# CVE-2026-73069: Twenty: SQL Injection in the `searchVector` Field Settings Allows Arbitrary PostgreSQL Execution

> A workspace administrator can execute arbitrary PostgreSQL commands via SQL injection in the searchVector field settings, compromising the database.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** GHSA-mm7j-q9q3-qqwj

## What is CVE-2026-73069?

CVE-2026-73069 is a critical SQL injection vulnerability in twentyhq twenty, published on 11 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Twenty is an open-source CRM (customer relationship management) platform. Prior to 2.15.0, Twenty allowed a workspace administrator with the DATA_MODEL permission to supply settings.asExpression for the system TS_VECTOR field searchVector through PATCH /rest/metadata/fields/:id or the updateOneField GraphQL mutation, causing buildSqlColumnDefinition in packages/twenty-server/src/engine/twenty-orm/workspace-schema-manager/utils/build-sql-column-definition.util.ts to concatenate unescaped input into GENERATED ALWAYS AS (...) and execute arbitrary PostgreSQL statements as the application database user. This issue is fixed in version 2.15.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-73069?


## How do I fix CVE-2026-73069?

No fix has been published for CVE-2026-73069 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73069 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73069 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73069 and fix it if it is affected.

What it is: CVE-2026-73069 is a critical SQL injection vulnerability in twentyhq twenty, published on 11 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73069 exists.

Affected product: twentyhq twenty. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73069/ (Markdown: https://insights.sbomify.com/CVE-2026-73069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73069
- OSV: https://osv.dev/vulnerability/CVE-2026-73069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73069/
Summaries are generated and may contain mistakes; the official description above is the record.
