CVE-2026-73070 Vim: Stack Buffer Overflow in the Vim Socket Server

Medium 6.8 Published Updated

A local attacker can exploit a stack buffer overflow in Vim's socket server to corrupt memory, potentially executing code or crashing the application.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-73070?

CVE-2026-73070 is a medium-severity memory corruption vulnerability in Vim Vim, published on 11 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Vim is an open source, command line text editor. Prior to 9.2.0842, the socket server backend in src/socketserver.c accepts unbounded client connections in socketserver_accept(), causing descriptors to overflow fd_set structures in src/channel.c and fixed-size struct pollfd arrays in src/os_unix.c, which allows a local process that can connect to the server socket to corrupt stack memory or terminate the Vim server. This issue is fixed in version 9.2.0842.

Weakness: CWE-121

Which versions are affected by CVE-2026-73070?

It affects 1 product.

Linux distribution packages (9)
vim Red Hat:hummingbird:1All versions0:9.2.967-1.hum1
vim-X11 Red Hat:hummingbird:1All versions0:9.2.967-1.hum1
vim-common Red Hat:hummingbird:1All versions0:9.2.967-1.hum1
vim-data Red Hat:hummingbird:1All versions0:9.2.967-1.hum1
vim-default-editor Red Hat:hummingbird:1All versions0:9.2.967-1.hum1
vim-enhanced Red Hat:hummingbird:1All versions0:9.2.967-1.hum1
vim-filesystem Red Hat:hummingbird:1All versions0:9.2.967-1.hum1
vim-minimal Red Hat:hummingbird:1All versions0:9.2.967-1.hum1
xxd Red Hat:hummingbird:1All versions0:9.2.967-1.hum1

Products include Vim Vim.

How do I fix CVE-2026-73070?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-73070 being exploited?

There is no known exploitation of CVE-2026-73070 in the wild and no public exploit code.

All Vim Vim vulnerabilities

Sources

Also known as ALPINE-CVE-2026-73070, AZL-95565, BELL-CVE-2026-73070, DEBIAN-CVE-2026-73070, ECHO-9c0f-ed25-4506, GHSA-49m8-wwxj-mr69 and 2 more.

Is CVE-2026-73070 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free