# CVE-2026-73070: Vim: Stack Buffer Overflow in the Vim Socket Server

> A local attacker can exploit a stack buffer overflow in Vim's socket server to corrupt memory, potentially executing code or crashing the application.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** ALPINE-CVE-2026-73070, AZL-95565, BELL-CVE-2026-73070, DEBIAN-CVE-2026-73070, ECHO-9c0f-ed25-4506, GHSA-49m8-wwxj-mr69, MINI-2579-877r-6c2f, RHSA-2026:56636

## What is CVE-2026-73070?

CVE-2026-73070 is a medium-severity memory corruption vulnerability in Vim Vim, published on 11 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Vim is an open source, command line text editor. Prior to 9.2.0842, the socket server backend in src/socketserver.c accepts unbounded client connections in socketserver_accept(), causing descriptors to overflow fd_set structures in src/channel.c and fixed-size struct pollfd arrays in src/os_unix.c, which allows a local process that can connect to the server socket to corrupt stack memory or terminate the Vim server. This issue is fixed in version 9.2.0842.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-73070?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vim` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |
| `vim-X11` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |
| `vim-common` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |
| `vim-data` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |
| `vim-default-editor` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |
| `vim-enhanced` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |
| `vim-filesystem` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |
| `vim-minimal` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |
| `xxd` | Red Hat:hummingbird:1 | All versions | 0:9.2.967-1.hum1 |

Products: Vim Vim.

## How do I fix CVE-2026-73070?

Upgrade to a fixed version.

## Is CVE-2026-73070 being exploited?

There is no known exploitation of CVE-2026-73070 in the wild and no public exploit code.

## Other vulnerabilities in Vim Vim

- [CVE-2020-20703](https://insights.sbomify.com/CVE-2020-20703/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-6349](https://insights.sbomify.com/CVE-2017-6349/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-6350](https://insights.sbomify.com/CVE-2017-6350/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-5953](https://insights.sbomify.com/CVE-2017-5953/): Integer overflow in n/a (critical 9.8)
- [CVE-2008-3075](https://insights.sbomify.com/CVE-2008-3075/): Command injection in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73070 and fix it if it is affected.

What it is: CVE-2026-73070 is a medium-severity memory corruption vulnerability in Vim Vim, published on 11 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73070 in the wild and no public exploit code.

Affected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73070/ (Markdown: https://insights.sbomify.com/CVE-2026-73070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73070
- OSV: https://osv.dev/vulnerability/CVE-2026-73070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73070/
Summaries are generated and may contain mistakes; the official description above is the record.
